HM3 Save Dialog Bug Fix

Earlier today I changed a setting for how ads are displayed in HM3. In a word, it was broken before -- ads weren't clickable in most of the major browsers. So I changed the stacking order of the app and the ad and now the ads actually function. Hooray! Before they were just annoying without actually generating revenue but now they do both!

Unfortunately that introduced several problems, one of which was the cancel button on the Save dialog box was obscured by the ad. That's been fixed now (you might have to clear your browser cache).

The other major problem is that the ads also show on the full-screen preview. I don't know how to fix that but I'll start working on it tomorrow.

13 Responses to HM3 Save Dialog Bug Fix

  1. So when I use Explorer, when I initially load the program everything looks good. The menu window looks like it’s in the right place beside the ad box, unobstructed. When I click to load a character, it reverts to the old placement under the ad box. I did clear my cache, but it still does the same thing. If I use Chrome, The menu window stays where it suppose to no matter what I click on.

  2. I would bet IE is still loading the out of date version of the swf file. It should clear up in a day or so — the right one is out there.

  3. Ok. I’ll use Chrome and test Explorer tomorrow. I’ll let you know.

  4. JEFF! Glad to see you in the IT department today. Your characters are going well too.

    See ya, man.

  5. No change yet with Explorer Jeff. And I noticed on Chrome when you want to “Clear All”, that the menu box is under the ad so you could not cancel if you wanted to. Let you know if I find anything else. Cheers!

  6. D’oh, thanks AMS. I’ll get that clear all box fixed up.

  7. All righty, the “Clear All” dialog box has been moved so it’s not obscured by the ad any more.

    I can’t figure out how to make it so that the ad is both clickable and disappears during the preview. It’s probably going to end up staying this way for the foreseeable future 🙁

  8. Jeff Hebert:
    All righty, the “Clear All” dialog box has been moved so it’s not obscured by the ad any more.

    I can’t figure out how to make it so that the ad is both clickable and disappears during the preview. It’s probably going to end up staying this way for the foreseeable future :-(

    Well it is what it is, can’t ask you to give up the ad money for HM3 though I really hate having that ad sitting in the wide screen as I do not use or like to use the export feature and much MUCH prefer taking Screenshoots to save my Heromachine characters.

  9. Maybe changing the setup to have a banner ad along the top? Just throwing out suggestions…

    Really affects the big caped or spread winged characters.

  10. I hear you, AMS, and I agree it’s a pain.

  11. Hey Jeff these are the 3 things that I seem to be encountering since your last update. I got some pictures to show the others to see if it`s just my computer or if they are experiencing the same things.
    1) On Explorer – The Adobe Flash`Player Setting window keeps popping up and freezes on the screen. In the past I could just hit the allow button and everything would be working. Now it just gets stuck.
    http://www.heromachine.com/wp-content/legacy/forum-image-uploads/ams/2013/11/info-for-Jeff.PNG
    2)In Explorer – The main menu screen does start in the right position off the ad window but when I select Load it moves back to the original position.
    http://www.heromachine.com/wp-content/legacy/forum-image-uploads/ams/2013/11/info-for-jeff-1.PNG
    3) In Chrome – The program seems to work better in here but I noticed some weird artifacting when making adjustments. Never saw these before. I have only seen it over the Move controls in the bottom right quadrant.
    http://www.heromachine.com/wp-content/legacy/forum-image-uploads/ams/2013/11/info-for-Jeff-chrome.PNG

    Let you know if I come across anything else. Hopefully, I not being a pain in a**.

    Cheers.

  12. Much appreciated, thanks AMS!

  13. The issue in Explorer with the load screen moving back under the ad window seems to be fixed now.