Category Archives: Bug Reports & Fixes

Find out if what’s going wrong is something we already know about, and if it’s already been fixed.

Bit of Server Tweaking.

Hi!

We just did a bit of server tweaking to address some of the slowdowns people have been experiencing lately. If you run into any issues, please comment on this post.

Thanks!

HeroMachine – Site Upgrade in Progress

Hey, folks!

We’ve moved HeroMachine.com to it’s snazzy new server. Most things are up and functional, but we’re still encountering a few bugs, specifically:

  • logging into the forums is problematic
  • some premium content may be unavailable

We’re working overtime to correct these bugs, and we’ll let you know when they’re fixed.

If you’re having any other issues with the site, please comment on this post.

Thanks, and sorry for any inconvenience!

– Ben

META: Export issues?

I’ve had half a dozen reports in the last few days of not being able to export images, has anyone here seen that? It works fine when I test it but these folks are telling me they get the popup window, only they never get the image.

Thanks for any feedback you can provide.

HM3: Printing

Is anyone having trouble printing directly from HM3? I’m having trouble getting the image to appear properly using the built-in “print” button, it cuts it off.

HM3: Wherein bugs are squashed and a question asked

With thanks to Panner and MMI, I’ve just updated the HeroMachine 3 Alpha with some more bug fixes:

  • The alpha transparency settings for all colors (especially color2) should now be working properly when you add additional items.
  • You can now switch on “Multiples”, add two of the same item, switch to “Single”, add a different item, and the previous items will correctly be removed without giving you “stuck” objects.
  • You can now drag items with the mouse wherever you want, even off-screen. Previously you were limited to dragging items only within the composition window.

Thanks to both of those folks for their excellent troubleshooting and bug reporting, it made squashing the bugs much much easier.

My question for you all regards automatic masking.

Currently, let’s say you have one item (for example, a square insignia) masked to another (like a body). Here’s how that looks:

But then you decide you want to add a second item from the same slot. In our example let’s say we wanted to add the chevron insignia. We select “Multiples” in Insignia, then click the chevron. The old item, the square, becomes UNmasked from the body, and the new item, the chevron gets masked instead, like this:

The question is, when you add a second item from a given slot (like the chevron insignia), would you prefer that the masking on the previous item (the square insignia) stay applied? Or would you prefer to keep it like it is now, where masking transfers to the new item along with colors and such and the old item is unmasked?

HM3: Bug tweaks for layering

I just posted a minor update to HeroMachine3 that hopefully will fix some of the layering and “stuck item” problems people were having when loading up saved characters.

I’ll explain the nitty gritty after the jump for those who are interested.

Continue reading

HM3: PNG and JPG fix

I think I’ve fixed the HM3 Alpha problem where using “Save as JPG/PNG” would squeeze your character into the upper left corner of the image if you used the left or right Hand. It now sets the image size to 400×600, which means wingtips and such will get cut off. But, it returns those features to basic usability, at least.

It also hopefully sets the stage for the “choose super big size” option down the road. In fact, I think I can by default set it to larger than 400×600 if you guys want, just let me know. This is all uncharted territory, I’m just hacking my way through it, but I’ll give it a whirl.

HM3: Good news and bad news

I’ve just uploaded an update for the HM3 alpha that hopefully will fix the problem with the layers getting hosed up beyond all belief when you load saved character. Unfortunately it looks like this has also broken the “Move to bottom” function and introduced a new error when loading a saved character where things are getting masked to the wrong items.

But, I wanted to put this up there for now to see if at least the layering problem is fixed. Give it a shot and let me know — I THINK you can load old characters and it ought to work properly.

HM3: Minor "TopsStandard" tweak

I just posted a slightly updated “TopsMaleStandard” set that fixes a patterning bug on one of the sleeveless items and on the ribbed t-shirt.

BUGS!

At the urging of both Damien and Violodion, I’ve put up a HeroMachine 3 Bugs page, perma-linked over there in the right column. I and Damien will try to keep that updated with your reports so I can remember not to forget what’s going on, and so you can quickly see if what’s happening to you is “normal bad” or “unusual bad”.